Support service disruption

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 12:07 UTC

Identified

Our engineering team has found an issue, and our support services are being restored
Posted Jun 26, 2025 - 07:59 UTC

Investigating

We are currently experiencing a communication outage due to an issue with our Support service system. As a result, our customer support services might be temporarily unavailable or work more slowly. We will keep you informed as the situation evolves.
Posted Jun 26, 2025 - 05:27 UTC