Server US-1918 Maintenance

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 10:39 UTC

Identified

US-1918 server located in The US is currently undergoing maintenance. Client websites hosted there could be temporarily inaccessible or might load slower than usual. We will provide further updates as necessary. Thank You for Your patience.
Posted Apr 01, 2025 - 10:24 UTC
This incident affected: Datacenters (BOS Datacenter).