Domain registration issues
Incident Report for
Hostinger
Resolved
This incident has been resolved.
Posted
Sep
07
,
2023
-
11:43
UTC
Investigating
One of our domain Registrar partners has intermittent issues which affects some domain registrations and other actions. Registrar's team is working on a fix and will provide an update as soon as possible.
Thank You for Your patience.
Posted
Sep
07
,
2023
-
09:44
UTC
×
Subscribe to Incident
Subscribe to updates for
Domain registration issues
via . You'll receive .