We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jul 10, 2026 - 09:17 UTC
Monitoring
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jul 10, 2026 - 09:05 UTC
Investigating
We’re investigating a service disruption affecting users on the Hostinger Horizons platform related with preview errors. Our team is working to identify the cause and restore normal operations as quickly as possible. We apologize for the inconvenience caused.
Posted Jul 10, 2026 - 08:42 UTC
This incident affected: Hostinger Horizons (Hostinger Horizons Editor).