hPanel Login Issues
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 08:10 UTC
Investigating
You may not be able to log into the hPanel. We have noticed an increased load in our backend infrastructure and are already working on a solution. Please note that no data will be lost, and your websites will not be affected. Thank You for your patience.
Posted Sep 18, 2024 - 08:04 UTC