Hostinger panel maintenance
Incident Report for Hostinger International
Resolved
This issue has been resolved
Posted Dec 04, 2019 - 12:18 UTC
Identified
We are performing Hostinger hPanel maintenance. During this time certain actions on hPanel may take longer to execute than usual.

Customer websites are not affected and will be functionating properly.
Apologies for any inconveniences. Thank you for your patience.
Posted Dec 04, 2019 - 12:03 UTC