DNS External Domain Management Issues

Incident Report for Hostinger

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Mar 23, 2026 - 14:02 UTC

Identified

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Mar 23, 2026 - 13:30 UTC

Investigating

We are currently investigating an issue affecting DNS management for external domains pointing to our nameservers. Some customers may experience difficulties managing DNS records for these domains during this time.
Our team is actively looking into the cause and working toward a resolution. Thank you for your patience.
Posted Mar 23, 2026 - 13:29 UTC
This incident affected: Core Services (Hostinger hPanel Frontend, Hostinger DNS).