Domain registration issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Sep 20, 2023 - 18:35 UTC

Investigating

One of our domain providers is currently experiencing temporary infrastructure issues that might directly impact our users who are trying to register or manage a domain. We are already working on a resolution and will update You in the process. Thank You for Your patience.
Posted Sep 20, 2023 - 14:40 UTC