Payments system downtime
Incident Report for
Hostinger
Resolved
Incident was fully restored, all payments received have been recorded.
Posted
May
22
,
2025
-
11:58
UTC
Monitoring
All traffic was restored.
Posted
May
22
,
2025
-
09:40
UTC
Update
About 70% of traffic should be restored, working on remaining
Posted
May
22
,
2025
-
09:23
UTC
Update
Major brands were restored
Posted
May
22
,
2025
-
09:13
UTC
Update
We are continuing to work on a fix for this issue.
Posted
May
22
,
2025
-
09:13
UTC
Identified
Issue has been identifying fixing the problem
Posted
May
22
,
2025
-
08:58
UTC
×
Subscribe to Incident
Subscribe to updates for
Payments system downtime
via . You'll receive .