Free mail service interruption
Incident Report for Hostinger International
Resolved
Mail service is running normal, no delays for outgoing mails.
Posted Oct 24, 2019 - 19:38 UTC
Monitoring
Mailchannels found the issue and fix has been implemented. Outgoing mails still are delayed due big queues, but are slowly falling. We will update status, once mail queues are reduced to minimum.
Posted Oct 24, 2019 - 17:58 UTC
Investigating
We are having issues with free mail services. Outgoing emails are delayed. This is due SMTP service outage on MailChannels.
Apologies for any inconveniences.
Posted Oct 24, 2019 - 16:25 UTC
This incident affected: E-mail Service (Outgoing E-mail).