hPanel Accessibility Issues

Incident Report for Hostinger

Resolved

The issue has been fixed.
Posted Sep 17, 2026 - 07:34 UTC

Monitoring

The issue has been resolved, and all affected functionality is now accessible. We are continuing to monitor the services to ensure stability.
Posted Sep 17, 2026 - 07:18 UTC

Investigating

Some hPanel actions, including email-related operations and adding SSH keys can be temporarily unavailable. No data loss or website impact is expected. The issue is being actively investigated. We apologize for any inconvenience caused.
Posted Sep 17, 2026 - 07:01 UTC
This incident affected: Core Services (Hostinger hPanel Backend, Hostinger hPanel Frontend).