Hostinger mail is experiencing Authenticate Access
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Nov 28, 2023 - 07:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2023 - 04:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 28, 2023 - 04:38 UTC
Investigating
Our mailer service is currently experiencing issues, which is affecting ability to Authenticate. We are actively investigating the issue and working to resolve it as quickly as possible.
Posted Nov 28, 2023 - 02:48 UTC
This incident affected: Email Hosting services (Hostinger Mail, Hostinger Webmail, Hostinger Mail SMTP Outbound).