hPanel Accessibility Issues
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted May 19, 2023 - 06:24 UTC
Investigating
We are currently investigating this issue.
Posted May 19, 2023 - 05:57 UTC
This incident affected: Core Services (Hostinger hPanel Backend, Hostinger hPanel Frontend).