All systems are operational at the UK data center. We continue to monitor the situation to ensure ongoing stability and performance.
Posted Jun 20, 2025 - 14:50 UTC
Update
We have implemented a fix for the network issue affecting email services, web servers, and VPS instances in our UK data center. Services are nearly fully restored, with only a minority of clients potentially experiencing intermittent impact. Our team is actively monitoring the situation to ensure full recovery and stable performance.
Posted Jun 20, 2025 - 14:22 UTC
Update
We’ve identified a network issue affecting email services, web servers, and VPS instances in our UK data center. Our team is actively working on a fix to restore full connectivity.
Posted Jun 20, 2025 - 13:56 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 20, 2025 - 13:15 UTC
Update
We are continuing to investigate this issue.
Posted Jun 20, 2025 - 13:01 UTC
Investigating
We are currently investingating this issue.
Posted Jun 20, 2025 - 12:44 UTC
This incident affected: Datacenters (ID Datacenter, UK Datacenter, LT Datacenter, PHX Datacenter, FR Datacenter, BOS Datacenter).