Our upstreams reported a fault with the submarine cable system which affects most of the traffic in India. The works have started to resolve the issue, no ETR is available, but we will share further updates as they become available.
Posted Jun 26, 2026 - 18:49 UTC
Update
We are aware of an upstream network issue affecting website performance for customers in our Mumbai (India) datacenter. We are in active communication with the provider and have escalated the issue. We are working hard to resolve this as quickly as possible. We apologize for the inconvenience caused.
Posted Jun 26, 2026 - 14:39 UTC
Update
One of our providers is currently experiencing network issues that may directly impact website performance for customers hosted in the Mumbai datacenter in India. We have contacted the related upstream provider and are actively working on a resolution. The upstream team has acknowledged the issue and provided an estimated resolution time of 4 hours. We will keep you updated throughout the process. Thank you for your patience
Posted Jun 26, 2026 - 10:09 UTC
Identified
One of our providers is currently experiencing network issues that may directly impact website performance for customers hosted in our India (Mumbai) datacenter. We have contacted the related upstream provider and are actively working on a resolution. We will keep you updated throughout the process. Thank you for your patience
Posted Jun 26, 2026 - 08:08 UTC
Investigating
One of our providers is currently experiencing network issues that may directly impact website performance for customers hosted in our India (Mumbai) datacenter. We are actively working on a resolution and will keep you updated throughout the process. Thank you for your patience.