Emergency Server US-631 Maintenance

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 06:05 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2025 - 06:00 UTC

Investigating

We are performing an emergency maintenance on server US-631, located in US. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.
Posted Feb 24, 2025 - 05:19 UTC