Free email service message delays
Incident Report for Hostinger International
Resolved
This incident has been resolved.
Posted Nov 20, 2019 - 19:36 UTC
Identified
Due to most recent service interruptions in networking, we are experiencing higher than usual message queue. Please be aware that all messages will be received but with a slight delay. Estimated time of queue normalization - 1-2 hours. Thank you.
Posted Nov 20, 2019 - 18:33 UTC
This incident affected: E-mail Service (Incoming E-mail).