hPanel email section: Free emails maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 17:52 UTC
Identified
We are currently performing maintenance on new email accounts creation/existing accounts management page in hPanel. Apologies for any inconvenience. Thank you for your patience
Posted Jul 16, 2020 - 15:34 UTC