The issue has been resolved. We apologize for any inconvenience caused, and thanks for your patience.
Posted May 17, 2026 - 03:25 UTC
Monitoring
The fix has been applied and we are closely monitoring the situation.
Posted May 17, 2026 - 02:32 UTC
Identified
The fix is in progress.
Posted May 17, 2026 - 00:47 UTC
Investigating
We are currently experiencing degraded performance issues on U4S Node-2, located in Kuala Lumpur. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.