Hostinger Webmail – Service Disruption

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 13:17 UTC

Update

A fix has been implemented and the webmail interface is loading again. We are currently monitoring to confirm full resolution.
Posted Mar 31, 2026 - 12:38 UTC

Monitoring

We're investigating the issue.
Posted Mar 31, 2026 - 11:50 UTC

Investigating

We are currently experiencing an issue affecting Hostinger Webmail. Users may be unable to load the webmail interface. Our engineering team is actively investigating and working to restore full functionality. We will provide updates as more information becomes available.
Posted Mar 31, 2026 - 11:42 UTC
This incident affected: Hostinger Email (Hostinger Webmail).