Free mail service
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Mar 24, 2020 - 20:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2020 - 15:05 UTC
Investigating
We are performing Free Mail service maintenance for Webmail client. Clients will experience from 10 to 60 minutes long service interruptions while using Hostinger Webmail client. Apologies for any inconveniences. Thank you for your patience.
Posted Mar 24, 2020 - 13:35 UTC
This incident affected: Core Services (Email service).