Free mail service maintenance
Incident Report for Hostinger International
Resolved
The issue has been resolved.
Posted Oct 01, 2019 - 16:25 UTC
Investigating
We are having issues with free mail services. Outgoing emails might have a delay, Our engineers are working on a fix.
We expect degraded performance for the next 2-3 hours. We will update status as soon issue will be resolved. Apologies for any inconveniences.
Posted Oct 01, 2019 - 13:50 UTC
This incident affected: E-mail Service (Outgoing E-mail).