Domain registration/management issues

Incident Report for Hostinger

Resolved

We think the impact from the issue is over.
Posted Apr 28, 2026 - 15:54 UTC

Update

We are currently experiencing an issue with our infrastructure. As a result, all domain management and registration services are affected.
Our team is actively investigating the root cause and working to resolve this as quickly as possible. We will provide a further update shortly.
We apologize for the inconvenience.
Posted Apr 28, 2026 - 14:09 UTC

Investigating

We are having issues with domains infrastructure, we are working to resolve it
Posted Apr 28, 2026 - 13:51 UTC
This incident affected: Core Services (Domain Registration & Management System).