Domain management issues
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Mar 14, 2023 - 08:27 UTC
Investigating
One of our domain providers is currently experiencing temporary infrastructure issues that might directly impact our users who are trying to register, renew or manage domains. We are already working on a resolution and will update You in the process. Thank You for Your patience.
Posted Mar 14, 2023 - 06:03 UTC
This incident affected: Core Services (Hostinger DNS).