Our partners have confirmed to have resolved the incident.
Posted Feb 14, 2026 - 23:44 UTC
Monitoring
We're in contact with affected partners and have identified the root cause of the network issue. Our team has applied additional fixes to mitigate the impact and is continuing to monitor the situation closely.
Posted Feb 14, 2026 - 21:47 UTC
Investigating
One of our providers is currently experiencing network issues that may directly impact clients in our Netherland and Germany data centers. We are currently working on a resolution and will update You in the process. Thank You for Your patience.
Posted Feb 14, 2026 - 21:33 UTC
This incident affected: Datacenters (NL Datacenter, DE Datacenter).