Server 291 maintenance
Incident Report for Hostinger International
Resolved
The maintenance has been finished.
Posted 8 days ago. Aug 09, 2019 - 22:45 UTC
Identified
We are performing maintenance on server 291, we hope to complete it within the next few hours. Thank You for Your patience and understanding regarding this matter.
Posted 8 days ago. Aug 09, 2019 - 22:32 UTC