Domain registration issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Sep 12, 2023 - 11:16 UTC

Investigating

One of our domain Registrar partners has intermittent issues which affects some domain registrations and other actions. Registrar’s team is working on a fix and will provide an update as soon as possible.
Thank You for Your patience.
Posted Sep 12, 2023 - 10:56 UTC