Titan Mail Delivery Issues
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 18:16 UTC
Investigating
You may experience ingoing and outgoing mail delays while using Titan mail services. We have noticed temporary problems with our direct provider Titan email. Please note, that no emails will be lost during delivery and regular mail functionality will be restored in a timely manner. Thank You for Your patience.
Posted Jan 24, 2023 - 16:27 UTC
This incident affected: Email Hosting services (Hostinger Mail).