Emergency Server NL-447 Maintenance

Incident Report for Hostinger

Resolved

Incident has been fixed.
Posted Jun 28, 2026 - 17:53 UTC

Monitoring

A fix has been pushed and we are monitoring the results.
Posted Jun 28, 2026 - 16:55 UTC

Identified

We have identified the issue and are working to restore service. Our engineering team is actively investigating and resolving the problem. Further updates will be provided as they become available.
Posted Jun 28, 2026 - 16:46 UTC

Investigating

We are performing an emergency maintenance on server 447, located in NL. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.
Posted Jun 28, 2026 - 14:58 UTC