cPanel Accessibility Issues on uk-cpl104

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Mar 22, 2026 - 23:38 UTC

Update

We are continuing to investigate this issue.
Posted Mar 22, 2026 - 21:18 UTC

Investigating

You may not be able to reach or see continuous loading on the cPanel product related panel areas on uk-cpl104. We have noticed an increased load in our backend infrastructure and are already working on a solution. Please note, that no data will be lost and Your websites will not be affected. Thank You for Your patience.
Posted Mar 22, 2026 - 16:19 UTC
This incident affected: Core Services (Hostinger hPanel Backend, Hostinger hPanel Frontend).