.EU domain registry issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Nov 20, 2024 - 19:20 UTC

Investigating

.EU domains registry is currently experiencing temporary infrastructure issues that might directly impact our users who are trying to purchase/register/manage an .EU domain. Thank You for Your patience.
Posted Nov 20, 2024 - 16:12 UTC