hPanel Domain management panel maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jul 15, 2020 - 14:34 UTC
Identified
We are currently applying some changes to domains management section in the main hosting panel. It may be unaccessible or redirect to the previous page. We apologize for any troubles it might cause and expect for the service to be fully functional in a few hours at most.
Posted Jul 15, 2020 - 12:52 UTC
This incident affected: Core Services (Hostinger Internal).