We identified the issue, we applied a mitigation and currently monitoring the result. We apologize for the inconvenience caused.
Posted Sep 08, 2026 - 14:17 UTC
Investigating
You may experience incoming and outgoing mail delays. We have noticed a sudden increase in Mail Queue and are currently looking into the issue. Please note, that no emails will be lost during delivery and regular mail functionality will be restored in a timely manner. Thank You for Your patience.
Posted Sep 08, 2026 - 13:50 UTC
This incident affected: Hostinger Email (Hostinger Mail, Hostinger Webmail, Hostinger Mail SMTP Outbound, Hostinger Mail IMAP/POP3 services, Hostinger Mail SMTP Inbound).