Investigating
Incident Report for
Hostinger
Resolved
We think the impact from the issue is over.
Posted
Apr
23
,
2026
-
23:27
UTC
Investigating
We are investigating a incident in the server 1979 located in india, services could not work properly or load slower than usual
Posted
Apr
23
,
2026
-
23:00
UTC
×
Subscribe to Incident
Subscribe to updates for
Investigating
via . You'll receive .