Support Platform Accessibility issues
Incident Report for
Hostinger
Resolved
Issue is resolved
Posted
Jun
17
,
2026
-
15:11
UTC
Identified
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted
Jun
17
,
2026
-
15:08
UTC
Investigating
We've spotted that something has gone wrong with our Support Platform. We're currently investigating the issue, and will provide an update soon.
Posted
Jun
17
,
2026
-
15:01
UTC
This incident affected: Core Services (Client Portal, Support Portal, Hostinger DDoS Protection).
×
Subscribe to Incident
Subscribe to updates for
Support Platform Accessibility issues
via . You'll receive .