Hostinger clients area - slow action processing
Incident Report for Hostinger International
Resolved
This incident has been resolved.
Posted 19 days ago. Jul 30, 2019 - 20:08 UTC
Investigating
Some clients may experience slowness in Hostinger clients area while processing actions.
We are investigating what caused it. We will keep updating.
Posted 19 days ago. Jul 30, 2019 - 19:14 UTC