Webmail Accessibility Issues
Incident Report for
Hostinger
Resolved
This incident has been resolved.
Posted
Nov
11
,
2025
-
10:25
UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Nov
11
,
2025
-
10:22
UTC
Identified
The issue has been identified and a fix is being implemented.
Posted
Nov
11
,
2025
-
10:17
UTC
Investigating
You may experience issues using our Webmail service (mail.hostinger.com).
Some users may encounter difficulties logging in or performing certain actions, such as reading, composing, or sending emails.
We are currently investigating the issue and working to restore normal functionality as quickly as possible.
Posted
Nov
11
,
2025
-
09:32
UTC
This incident affected: Hostinger Email (Hostinger Webmail).
×
Subscribe to Incident
Subscribe to updates for
Webmail Accessibility Issues
via . You'll receive .