A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2025 - 18:14 UTC
Investigating
We are currently experiencing degraded email delivery on our platform. We are currently in contact with our third-party provider, Mailchannels, to resolve issues. Please note that no emails will be lost during delivery, and regular mail functionality will be restored in a timely manner. Thank You for your patience.
Posted Feb 12, 2025 - 14:43 UTC
This incident affected: Email Hosting services (MailChannels service, Hostinger Mail SMTP Outbound, Hostinger Mail SMTP Inbound).