Core Infrastructure Connectivity Issues

Incident Report for Hostinger

Resolved

This incident has been resolved. We apologize for any inconvenience caused
Posted Nov 25, 2025 - 04:19 UTC

Update

Services are currently being restored. We are monitoring the results to ensure full recovery and stability. We will update you in the next 1 hour.
Posted Nov 25, 2025 - 03:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results. We will update you in the next 1 hour.
Posted Nov 25, 2025 - 02:33 UTC

Update

Mitigation efforts with our service providers remain ongoing. We will share the next update within the next 1 hour, or sooner if we have meaningful progress.
Posted Nov 25, 2025 - 01:55 UTC

Update

We are still actively trying to mitigate the issues along with our service providers to bring back our services back to normal operations.
Posted Nov 25, 2025 - 01:07 UTC

Update

We are still actively trying to mitigate the issues along with our service providers to bring back our services back to normal operations.
Posted Nov 25, 2025 - 00:33 UTC

Update

We are still actively trying to mitigate the issues along with our service providers to bring back our services back to normal operations.
Posted Nov 25, 2025 - 00:20 UTC

Identified

We’ve identified that the issue is being caused by an unexpected large increase in DNS traffic coming through one of our service providers. We’re coordinating with them to fix the problem and bring services back to normal operations.
Posted Nov 25, 2025 - 00:12 UTC

Investigating

Widespread service degradation impacting hPanel, Builder, Horizons, email services, websites and hCDN. Root cause under investigation. Mitigation measures in progress.
Posted Nov 24, 2025 - 23:58 UTC
This incident affected: Hostinger Email (Hostinger Mail), Hostinger Shared Hosting (LT-BNK Shared servers (Vilnius, LT), US-IMM Shared servers (Asheville, US), SG-NME Shared servers (Singapore, SG), NL-SRV Shared servers (Amsterdam, NL), UK-FAST Shared servers (Manchester, UK), US-PHX Shared servers (Phoenix, US), IN-MUM Shared servers (Mumbai, IN), BR-ASC Shared servers (São Paulo, BR), ID-DCI Shared servers (Jakarta, ID), FR-INT Shared servers (Paris, FR), DE-FRA Shared servers (Frankfurt, DE), US-BOS Shared servers (Boston, US), MailChannels SMTP Service), Hostinger Cloud Hosting (US-IMM Cloud servers (Asheville, US), LT-BNK Cloud servers (Vilnius, LT), SG-NME Cloud servers (Singapore, SG), NL-SRV Cloud servers (Amsterdam, NL), UK-FAST Cloud servers (Manchester, UK), US-PHX Cloud servers (Phoenix, US), IN-MUM Cloud servers (Mumbai, IN), BR-ASC Cloud servers (São Paulo, BR), ID-DCI Cloud servers (Jakarta, ID), FR-INT Cloud servers (Paris, FR), DE-FRA Cloud servers (Frankfurt, DE), US-BOS Cloud servers (Boston, US), MailChannels SMTP Service), and Core Services (Hostinger Websites, Hostinger hPanel Backend, Hostinger hPanel Frontend, Hostinger DNS, Hostinger CDN, Domain Registration & Management System).