Our team continues to monitor the cPanel DNS service. Intermittent unavailability of some cPanel-hosted websites may persist for the next few hours as maintenance and deployment activities continue. We are working to restore normal service as quickly as possible and will provide further updates.
Posted Mar 26, 2026 - 19:01 UTC
Update
We are continuing to investigate this issue.
Posted Mar 26, 2026 - 18:51 UTC
Investigating
We are currently experiencing issues affecting our cPanel DNS service and are performing emergency maintenance. This may cause intermittent unavailability of some cPanel-hosted websites.
Our team is actively monitoring the situation and taking steps to mitigate the impact while working to restore normal service as quickly as possible.
We apologize for any inconvenience caused.
Posted Mar 26, 2026 - 17:36 UTC
This incident affects: Core Services (Hostinger DNS).