.FR Domain registration and management issues

Incident Report for Hostinger

Resolved

We think the impact from the issue is over.
Posted Apr 16, 2026 - 15:38 UTC

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Apr 16, 2026 - 10:24 UTC