Email Service Degraded Performance
Incident Report for
Hostinger
Resolved
The incident has been resolved.
Posted
May
26
,
2026
-
07:54
UTC
Monitoring
We've monitoring the fix.
Posted
May
26
,
2026
-
05:34
UTC
Investigating
We’re investigating an issue. Some users may also be unable to claim a free Hostinger email.
We apologize for the inconvenience and appreciate your patience.
Posted
May
26
,
2026
-
01:22
UTC
This incident affected: Hostinger Email (Hostinger Mail).
×
Subscribe to Incident
Subscribe to updates for
Email Service Degraded Performance
via . You'll receive .