Issues with Hostinger hPanel
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 15:47 UTC
Investigating
We are currently investigating minor issues with Hostinger hPanel. A subset of users are impacted and we are actively working to resolve this. We will inform about more details as soon as they are available. Thank You for Your patience.
Posted Jul 30, 2020 - 15:30 UTC