Temporary hPanel loading issues
Incident Report for Hostinger International
Resolved
This incident has been resolved.
Posted Nov 27, 2019 - 03:30 UTC
Identified
There is currently an issue with hPanel not being loaded up properly. the Issue is known and should be resolved in the next hour. Thank You for the patience.
Posted Nov 27, 2019 - 02:54 UTC
This incident affected: Core Services (Hostinger Internal).