Disturbances with Printful integration in Website builder

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 09:54 UTC

Investigating

We are currently investigating why sometimes Printful gets disconnected for users.
Posted Sep 24, 2025 - 05:36 UTC
This incident affected: Hostinger Website Builder (Ecommerce).