Maintenance of Server 322 in Netherlands
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jun 21, 2021 - 16:16 UTC
Investigating
We are performing an emergency hardware maintenance on Server 322 in Netherlands. It’s crucial to ensure the continued upkeep and performance of your service. We will provide further updates as necessary. Thank you for your patience.
Posted Jun 21, 2021 - 15:39 UTC