Email Campaign Delivery Delays

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 16:43 UTC

Identified

We are currently experiencing temporary issues affecting email campaign delivery in Hostinger Reach. Some features may work with delays or limited functionality. Our team is working hard to resolve the issue.
Posted Jan 28, 2026 - 15:42 UTC

Update

We are continuing to investigate this issue.
Posted Jan 28, 2026 - 15:31 UTC

Investigating

We are currently experiencing temporary issues affecting email campaigns delivery in Hostinger Reach. Some features may work with delays or limited functionality. Our team is investigating, and we will provide updates as soon as possible.
Posted Jan 28, 2026 - 14:59 UTC