.ID domains registration/management issues

Incident Report for Hostinger

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 05:04 UTC

Investigating

.ID domains registry is having issues.
.ID domain registrations/renewals/management might be affected
Posted Apr 27, 2026 - 18:19 UTC
This incident affected: Core Services (Domain Registration & Management System).