Email Delivery Issues

Incident Report for Hostinger

Resolved

The incident has been fully resolved.
Posted Sep 30, 2025 - 16:49 UTC

Monitoring

A fix has been implemented for the mail delivery issue, and we are currently monitoring to ensure everything is working as expected.
Posted Sep 30, 2025 - 16:29 UTC

Investigating

Some users may experience delays with sending and receiving email. We have identified temporary issues with our external email provider (Mailchannels), which are currently affecting POP3 and outbound delivery. IMAP is working as expected.

No emails will be lost during delivery, and regular mail functionality will be restored as soon as possible.
Posted Sep 30, 2025 - 16:19 UTC
This incident affected: Hostinger Email (MailChannels service, Hostinger Mail SMTP Outbound, Hostinger Mail SMTP Inbound, MailChannels SMTP Service).