Emergency Server US-1452 Maintenance
Incident Report for Hostinger
Resolved
This incident has been resolved.
Posted Jun 29, 2024 - 21:00 UTC
Investigating
We are performing an emergency maintenance on server 1452, located in the USA. Client websites hosted there could be temporarily inaccessible or might load slower than usual. Our team is currently working to restore normal performance levels. We apologize for any inconvenience caused.
Posted Jun 29, 2024 - 20:55 UTC